Problem mit oEmbed und WordPress

Es klingt toll: Ich kopiere mir die Webadresse von einem Video auf YouTube und füge sie in einen Artikel ein und das Video wird einfach im Artikel angezeigt. Ohne Plugin und ohne html-Code.

Von der Theorie zur Praxis.

Ich erinnere mich, dass dies am Anfang in meinen Blogs sogar funktionierte. Immerhin habe ich in meinem P2 Blog anfangs jede Menge Videos hinterlegt. Eines Tages entdeckte ich, dass die meisten Videos nicht mehr automatisch angezeigt werden. Also fing ich an Fehlersuche zu betreiben.

  1. Standard Theme „Twenty Ten“ einschalten.
  2. Plugins abschalten
  3. Widgets abschalten
  4. sinnloses vergleichen der der Videos die angezeigt wurden und nicht angezeigt wurden
  5. Foren wälzen
  6. die Einstellungen in der Mediathek kontrollieren und austesten
  7. frischen Blog installieren.

Nichts brachte mich damals weiter. Monate lang habe ich kaum noch diese Funktion genutzt, da sie eh nicht zuverlässig lief. Von 10 Videos wurde nur 1 angezeigt.

Heute habe ich mich diesem noch einmal gewidmet. Von Punkt 1 bis 6 ging ich alles noch einmal durch. Und bei Punkt 6 stieß ich auf einen Hinweis. Hier kann man im Bereich „Einbettungen“ die maximale Breite und Höhe der Videos angeben. Meine Einstellung war Breite 500 Höhe stand auf 0, da diese automatisch angepasst wird. Sobald ich die Breite z.B. auf 600 veränderte wurden andere Videos angezeigt. Gleiches Spiel wenn ich diesen Wert verringerte oder für die Höhe anpasste.
Laut Text in den Einstellungen kann ich auch in der Breite nichts eintragen und die Breite des Videos passt sich an das Theme an.

Wenn die Angabe der Breite leer bleibt, werden eingebettete Elemente standardmäßig auf die maximale Breite deines Themes gesetzt.

Zumindest in meinen 4 WordPress Blogs klappt dies nicht.

Durch Zufall stieß ich auf der Supportseite von WordPress.org auf einen Artikel zum Thema Videos und WordPress. Neben dem was bei mir nicht funktioniert wird auch der ShortCode erwähnt, welcher Usern auf der Plattform von WordPress.com das Einbinden von Videos ermöglicht.

Da der ShortCode im eigenem Blog bekanntlich nicht funktioniert und somit für mich nicht von Nutzen ist wäre mir beinahe der Bereich Video Customization Options entgangen. Ist er jedoch nicht.
Das folgende Beispiel zeigt, wie man die Breite und Höhe für das Video festlegen kann.

Kurz entschlossen nahm ich &w=640 und fügte es an einem meiner Videos an. Und siehe da – das Video wird angezeigt. Zwei weitere Videos, welche sich nicht mehr anzeigen lassen wollten erhielten von mir die gleiche Behandlung. Und wieder ein Erfolg. Da ich keine Lust habe an jedes meiner Videos diese Endung anzuhängen übernahm ich diesen Wert i Admin-Bereich:
Einstellungen -> Mediathek -> Einbettungen -> Breite = 640

Nachdem ich dies Änderungen übernommen hatte war jedes meiner Videos wieder sichtbar.
http://rl.villa-vampyria.de/archives/tag/video

Persönlich kann ich in meinen genutzten Themes die 40 Pixel verkraften. Mich interessiert jedoch, ob es weitere WordPress Nutzer gibt, die dieses Problem kennen und es eventuell sogar beheben konnten. In den Supportforen zumindest finden sich hin und wieder Anfragen zu diesem Thema. Leider ohne Lösungen. Viele User kennen diese Möglichkeit Videos einzubinden gar nicht und nutzen Plugins dafür. Eine Lösung, die für mich jedoch nicht in Frage kommt.

 

Dunkle Grüße – blue-matrix

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.